summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-10 16:32:26 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-10 16:32:26 +0200
commitece0773ca85bf8a7235795ead111bf971312c80b (patch)
tree2e38d68315ba573bab87bde8c559417b9fea2c95 /configure.ac
parentcf787bc8723fec137d0e8d366d517d8b929547c6 (diff)
downloadcuirass-ece0773ca85bf8a7235795ead111bf971312c80b.tar
cuirass-ece0773ca85bf8a7235795ead111bf971312c80b.tar.gz
build: Prefer building with Guile 2.2.
* Makefile.am (guilesitedir): Append @GUILE_EFFECTIVE_VERSION@. * configure.ac: Use 'GUILE_PKG', and pass "2.2" first.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 900fa01..0be5456 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,7 @@
## Process this file with autoconf to produce a configure script.
# Copyright © 2016, 2017 Mathieu Lirzin <mthl@gnu.org>
+# Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
#
# This file is part of Cuirass.
#
@@ -33,7 +34,12 @@ AC_CANONICAL_HOST
AC_PROG_MKDIR_P
AC_PROG_SED
-PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.7])
+GUILE_PKG([2.2 2.0])
+
+if test "x$GUILE_EFFECTIVE_VERSION" = "x2.0"; then
+ PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.7])
+fi
+
AC_PATH_PROG([GUILE], [guile])
AC_PATH_PROG([GUILD], [guild])
AS_IF([test -z "$ac_cv_path_GUILD"],