summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-07-16 18:16:39 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-07-25 02:12:39 +0200
commit46c9d432eaa86d1733fd9a4c67f2302e072d6f8a (patch)
treee5965b69439ab748c8ea038ad73d3628237b52e4 /configure.ac
parent730832c2fbb63da7278115b35d552b088a1a0a1b (diff)
downloadcuirass-46c9d432eaa86d1733fd9a4c67f2302e072d6f8a.tar
cuirass-46c9d432eaa86d1733fd9a4c67f2302e072d6f8a.tar.gz
database: Use an external SQL schema.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 945260c..61f5d0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,11 +8,13 @@ AM_SILENT_RULES([yes]) # enables silent rules by default
AC_CANONICAL_HOST
-# Prepare a version of $localstatedir that does not contain references to
-# shell variables.
+# Prepare a version of installation directories that does not contain
+# references to shell variables.
expanded_prefix="`eval echo $prefix | sed -e "s|NONE|/usr/local|g"`"
-expanded_localstatedir="`eval echo $localstatedir | sed -e "s|NONE|$expanded_prefix|g"`"
-AC_SUBST([expanded_localstatedir])
+AC_SUBST([expanded_datadir],
+ [`eval echo $datadir | sed -e "s|NONE|$expanded_prefix|g"`])
+AC_SUBST([expanded_localstatedir],
+ [`eval echo $localstatedir | sed -e "s|NONE|$expanded_prefix|g"`])
PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.7])
AC_PATH_PROG([GUILE], [guile])