summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-12-24 01:08:04 +0100
committerMathieu Lirzin <mthl@gnu.org>2016-12-28 18:19:03 +0100
commit57e10c6056458a3456aaa030fe48babc72097ce7 (patch)
treebf1fce7daecd7d01d3904b690adfa14b2edddd45 /build-aux
parent16aec469d45a9339f117cd6427aebe8d7b80e5bc (diff)
downloadcuirass-57e10c6056458a3456aaa030fe48babc72097ce7.tar
cuirass-57e10c6056458a3456aaa030fe48babc72097ce7.tar.gz
build: Set Guile load paths in 'pre-inst-env'.
This reverts most of 4f0d665746e0c6efe43c0f281e0eaac5012c79da. The load paths are still hard coded after installation, however 'pre-inst-env' wrapper is used for defining them in the local build environment. This is more convenient for running the tests manually or launching a Guile REPL with all the Cuirass modules accessible. * build-aux/pre-inst-env.in (GUILE_LOAD_PATH, GUILE_LOAD_COMPILED_PATH): New variables. * bin/cuirass.in: Comment Guile load paths. * Makefile.am (local_load_path, local_load_compiled_path): Delete. (AM_TESTS_ENVIRONMENT): Don't set Guile load paths. (do_subst): Use install directories for Guile load paths. (install-exec-hook): Uncomment 'cuirass' hard coded load paths.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/pre-inst-env.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/build-aux/pre-inst-env.in b/build-aux/pre-inst-env.in
index abf9c35..c8deb2d 100644
--- a/build-aux/pre-inst-env.in
+++ b/build-aux/pre-inst-env.in
@@ -20,6 +20,10 @@
abs_top_srcdir="`cd "@abs_top_srcdir@" > /dev/null; pwd`"
abs_top_builddir="`cd "@abs_top_builddir@" > /dev/null; pwd`"
+GUILE_LOAD_COMPILED_PATH="$abs_top_builddir/src${GUILE_LOAD_COMPILED_PATH:+:}$GUILE_LOAD_COMPILED_PATH"
+GUILE_LOAD_PATH="$abs_top_builddir/src:$abs_top_srcdir/src${GUILE_LOAD_PATH:+:}$GUILE_LOAD_PATH"
+export GUILE_LOAD_COMPILED_PATH GUILE_LOAD_PATH
+
CUIRASS_DATADIR="$abs_top_srcdir/src"
export CUIRASS_DATADIR