aboutsummaryrefslogtreecommitdiff
path: root/bin/cuirass.in
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-09-21 18:41:44 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-09-29 17:02:45 +0200
commiteb8d1b88adcb63b12986855f40a454e2c59d0b9c (patch)
tree0bc7ff3f3b9a41620fe355a0fe762366037a5093 /bin/cuirass.in
parent0ffcb80ebbaa2b177f03548035a2ef21ae7ac41d (diff)
downloadcuirass-eb8d1b88adcb63b12986855f40a454e2c59d0b9c.tar
cuirass-eb8d1b88adcb63b12986855f40a454e2c59d0b9c.tar.gz
Add watchdog support.
* src/cuirass/watchdog.scm: New file. * Makefile.am (dist_pkgmodule_DATA): Add it. * src/cuirass/utils.scm (with-timeout, get-message-with-timeout): Export them. * bin/cuirass.in (main): Start the watchdog.
Diffstat (limited to 'bin/cuirass.in')
-rw-r--r--bin/cuirass.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/bin/cuirass.in b/bin/cuirass.in
index d6c2695..55e92b6 100644
--- a/bin/cuirass.in
+++ b/bin/cuirass.in
@@ -32,6 +32,7 @@ exec ${GUILE:-@GUILE@} --no-auto-compile -e main -s "$0" "$@"
(cuirass logging)
(cuirass metrics)
(cuirass utils)
+ (cuirass watchdog)
(guix ui)
((guix build utils) #:select (mkdir-p))
(fibers)
@@ -153,7 +154,7 @@ exec ${GUILE:-@GUILE@} --no-auto-compile -e main -s "$0" "$@"
(if one-shot?
(process-specs (db-get-specifications))
(let ((exit-channel (make-channel)))
-
+ (start-watchdog)
(if (option-ref opts 'web #f)
(begin
(spawn-fiber