summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-07-21 17:42:55 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-07-25 02:12:39 +0200
commitadc624c75a579677f35da60a7a01a2a988898e73 (patch)
tree82e756e90805df29b68a527287b6211f7582c87d /Makefile.am
parentf9938a3caa2c2158a18f2e25eb2d5bac3a4acfa0 (diff)
downloadcuirass-adc624c75a579677f35da60a7a01a2a988898e73.tar
cuirass-adc624c75a579677f35da60a7a01a2a988898e73.tar.gz
build: Add 'sql-check' rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fbaa7dc..fe97e91 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,6 +72,12 @@ gen-ChangeLog:
mv $(distdir)/cl-t $(distdir)/ChangeLog; } \
fi
+.PHONY: sql-check
+sql-check: src/schema.sql
+ @echo "$<"
+ $(AM_V_at)sqlite3 tmp-$$$.db < $< ; \
+ rm tmp-$$$.db
+
EXTRA_DIST = \
.dir-locals.el \
tests/gnu-system.scm \