summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-07-04 13:43:54 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-07-04 17:01:58 +0200
commit92f5d0dfe4ed885f32e6bd92a53e50f7fcaccbb6 (patch)
treeb7e0d13548908ea513aa27f5a10f4b62f3571ff2
parentecd001cb225cb71a1f8dac440a452b0372d1d594 (diff)
downloadcuirass-92f5d0dfe4ed885f32e6bd92a53e50f7fcaccbb6.tar
cuirass-92f5d0dfe4ed885f32e6bd92a53e50f7fcaccbb6.tar.gz
Add guix-jobs.scm specification file.
-rw-r--r--Makefile.am1
-rw-r--r--tests/guix-jobs.scm40
2 files changed, 41 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d558df..38e2442 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,6 +72,7 @@ gen-ChangeLog:
EXTRA_DIST = \
.dir-locals.el \
tests/gnu-system.scm \
+ tests/guix-jobs.scm \
tests/hello-subset.scm \
$(TESTS)
diff --git a/tests/guix-jobs.scm b/tests/guix-jobs.scm
new file mode 100644
index 0000000..9196147
--- /dev/null
+++ b/tests/guix-jobs.scm
@@ -0,0 +1,40 @@
+;;;; guix-jobs.scm - job specification test for Guix.
+;;;
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+;;;
+;;; This file is part of Cuirass.
+;;;
+;;; Cuirass is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Cuirass is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
+
+(use-modules (cuirass job))
+
+;; In the common case jobs will be defined relative to the repository.
+;; However for testing purpose use local gnu-system.scm instead.
+(define (local-file file)
+ (string-append (dirname (current-filename)) "/" file))
+
+(list (make-job-spec
+ #:name "guix"
+ #:url "git://git.savannah.gnu.org/guix.git"
+ #:load-path "."
+ #:branch "master"
+ #:file (local-file "gnu-system.scm")
+ #:proc 'hydra-jobs)
+ (make-job-spec
+ #:name "guix"
+ #:url "git://git.savannah.gnu.org/guix.git"
+ #:load-path "."
+ #:tag "v0.10.0"
+ #:file (local-file "gnu-system.scm")
+ #:proc 'hydra-jobs))