aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:05:39 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:59 +0100
commit7c44828fab9f1c32eb564749d472242df63573f3 (patch)
treeb15c1cc8bfc83ac4fbc7b0d13bd9a7a232ce707c /gnu
parentcddf767eed7322fb94c1ff31b2ba9613b28ad2b7 (diff)
downloadguix-7c44828fab9f1c32eb564749d472242df63573f3.tar
guix-7c44828fab9f1c32eb564749d472242df63573f3.tar.gz
gnu: Remove ocaml4.07-ppx-enumerate.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-enumerate): Remove variable. (ocaml-ppx-enumerate)[properties]: Remove variant. Change-Id: I4923573de50e9e1795562cc7b974b8da7c88a64c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 407a46d15d..a32d64bf6b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6917,8 +6917,7 @@ hash functions from type exrpessions and definitions.")
`(#:tests? #f)) ; no test suite
(propagated-inputs
(list ocaml-base ocaml-migrate-parsetree ocaml-ppxlib))
- (properties `((upstream-name . "ppx_enumerate")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-enumerate))))
+ (properties `((upstream-name . "ppx_enumerate")))
(home-page "https://github.com/janestreet/ppx_enumerate")
(synopsis "Generate a list containing all values of a finite type")
(description "Ppx_enumerate is a ppx rewriter which generates a definition
@@ -6926,24 +6925,6 @@ for the list of all values of a type (for a type which only has finitely
many values).")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-enumerate
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-enumerate)
- (name "ocaml-ppx-enumerate")
- (version "0.11.1")
- (home-page "https://github.com/janestreet/ppx_enumerate")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0spx9k1v7vjjb6sigbfs69yndgq76v114jhxvzjmffw7q989cyhr"))))
- (properties `((upstream-name . "ppx_enumerate"))))))
-
(define-public ocaml-ppx-bench
(package
(name "ocaml-ppx-bench")