aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:40:49 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 17:38:02 +0000
commit5d865504f238b5f629c5965cd2012aade826c5d5 (patch)
tree032c456ba5d597867ce4ddec6588b988e9a7458a /gnu
parent24aa5d01c31db2029ed9b8104576f5ff8d5b4054 (diff)
downloadguix-5d865504f238b5f629c5965cd2012aade826c5d5.tar
guix-5d865504f238b5f629c5965cd2012aade826c5d5.tar.gz
gnu: Add ruby-oj.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5860de5831..c1b7748c15 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5014,3 +5014,36 @@ in standard Ruby syntax.")
(home-page
"http://github.com/brianmario/yajl-ruby")
(license license:expat)))
+
+(define-public ruby-oj
+ (package
+ (name "ruby-oj")
+ (version "2.18.5")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Version on rubygems.org does not contain Rakefile, so download from
+ ;; GitHub instead.
+ (uri (string-append "https://github.com/ohler55/oj/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0mkg70j0f40910rji64q9yfpy7zp46ny5bhfhjax4ik1pg361cgw"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'compile
+ (lambda _
+ (zero? (system* "rake" "compile")))))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis
+ "The fastest JSON parser and object serializer. ")
+ (description
+ "The fastest JSON parser and object serializer. ")
+ (home-page "http://www.ohler.com/oj")
+ (license license:expat)))