aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-04-01 16:11:50 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:29:27 -0400
commit580d6ca5ce79989466e1edbe4712a54eb4ce5154 (patch)
treecb93a52c0c9096a12e86dc45f56f1afb5cadbe22 /gnu
parenta9b63e2be1dcf3fb5e6a44cac2fbaa8e0481332f (diff)
downloadguix-580d6ca5ce79989466e1edbe4712a54eb4ce5154.tar
guix-580d6ca5ce79989466e1edbe4712a54eb4ce5154.tar.gz
gnu: fcitx-qt5: Update to 1.2.7.
* gnu/packages/fcitx.scm (fcitx-qt5): Update to 1.2.7.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fcitx.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/fcitx.scm b/gnu/packages/fcitx.scm
index 5741b8d622..2143419d3b 100644
--- a/gnu/packages/fcitx.scm
+++ b/gnu/packages/fcitx.scm
@@ -52,7 +52,7 @@
(define-public fcitx-qt5
(package
(name "fcitx-qt5")
- (version "1.2.6")
+ (version "1.2.7")
(source
(origin
(method git-fetch)
@@ -63,7 +63,7 @@
(file-name
(git-file-name name version))
(sha256
- (base32 "13sanrir696fv7s44b7q453s5qi4r7ag0r3iyggyzk8xyf6rw8fk"))))
+ (base32 "1gw51m7hfnplkym33dzwfa8g0q20ji61pr80s2i6xhy2glrm1ssj"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f ; No target
@@ -71,12 +71,12 @@
(modify-phases %standard-phases
(add-after 'unpack 'patch-install-dir
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "quickphrase-editor/CMakeLists.txt"
+ (substitute* "qt5/quickphrase-editor/CMakeLists.txt"
(("\\$\\{FCITX4_ADDON_INSTALL_DIR\\}")
(string-append
(assoc-ref outputs "out")
"/lib/fcitx")))
- (substitute* "platforminputcontext/CMakeLists.txt"
+ (substitute* "qt5/platforminputcontext/CMakeLists.txt"
(("\\$\\{CMAKE_INSTALL_QTPLUGINDIR\\}")
(string-append
(assoc-ref outputs "out")