aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:35:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:38 +0200
commit2a5eebb748fe9c7a99a9606049a3c44fe7bba990 (patch)
tree9a89d7c0635d8dc76bbf7a702f5d7a9e8cc7cdd0 /gnu
parent61b78edef0cc8817e1a1edc45a234c7ff67f6492 (diff)
downloadguix-2a5eebb748fe9c7a99a9606049a3c44fe7bba990.tar
guix-2a5eebb748fe9c7a99a9606049a3c44fe7bba990.tar.gz
gnu: Add texlive-lyluatex.
* gnu/packages/tex.scm (texlive-lyluatex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5ab9064ab7..9ffe802a8d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9120,6 +9120,27 @@ LaTeX2e}.")
several languages not included in that package: BUGS, JAGS, and Stan.")
(license license:lppl1.3+)))
+(define-public texlive-lyluatex
+ (package
+ (name "texlive-lyluatex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/lyluatex/" "scripts/lyluatex/"
+ "tex/luatex/lyluatex/")
+ (base32
+ "04w57pki09mzhaxv3s1f2m0bj1df5aqxygqgrihvkabc5x00is87")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lyluatex")
+ (synopsis
+ "Commands to include LilyPond scores within a (Lua)LaTeX document")
+ (description
+ "This package provides macros for the inclusion of LilyPond scores within
+LuaLaTeX. It calls LilyPond to compile scores, then includes the produced
+files.")
+ (license license:expat)))
+
(define-public texlive-macros2e
(package
(name "texlive-macros2e")