aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-08-30 00:14:06 +0900
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-23 20:52:02 +0100
commitee2422cc3681a86d5dfe030561e36ea2467928be (patch)
tree8dc0d756e7c3f1c2be60a5e7c39ba40d2140abef /gnu/packages
parentdb85958f66f0362728bbbcaaa360257cd18e2824 (diff)
downloadguix-ee2422cc3681a86d5dfe030561e36ea2467928be.tar
guix-ee2422cc3681a86d5dfe030561e36ea2467928be.tar.gz
gnu: Add go-zgo-at-zli.
* gnu/packages/golang-xyz.scm (go-zgo-at-zli): New variable. Change-Id: Ia9ed0ffe30933848ecda0c9130f02285407572b1 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index fa6c8ff605..37d81a973f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -7400,6 +7400,31 @@ remains is just the @code{runewidth.RuneWidth()} function.")
terminals.")
(license license:expat)))
+(define-public go-zgo-at-zli
+ (package
+ (name "go-zgo-at-zli")
+ (version "0.0.0-20240922172047-d7bc84b1106f")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arp242/zli")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "110kwhydj6bzwqk7amkm9xgr3apx2bq6frlqb5yxds8cj5y25jks"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "zgo.at/zli"))
+ (home-page "https://github.com/arp242/zli")
+ (synopsis "Go library for writing command line interface programs")
+ (description
+ "@samp{zli} is a Go library for writing command line interface
+programs. It includes flag parsing, color escape codes, various
+helpful utility functions, and makes testing fairly easy.")
+ (license license:expat)))
+
(define-public go-zgo-at-zstd
(package
(name "go-zgo-at-zstd")