aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-19 17:31:45 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-19 21:45:47 +0900
commitecda7d3ef7c1b31d34a4353a2fd637b9d48d75a4 (patch)
treeb04d506104ef2a14e8c60e603c643d0abfd489ed /gnu/packages
parent1d07e429d94b48bc4d97710307c07d9b7724d59b (diff)
downloadguix-ecda7d3ef7c1b31d34a4353a2fd637b9d48d75a4.tar
guix-ecda7d3ef7c1b31d34a4353a2fd637b9d48d75a4.tar.gz
gnu: joycond: Update to 0.1.0-2.9d1f509, use gexps and fix license.
* gnu/packages/games.scm (joycond): Update to 0.1.0-2.9d1f509. [phases]: Use gexps. [license]: Correct to gpl3+. Change-Id: I81824de94d168e63e0434149805708cb1e8b8a54
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8137015fcf..2334442436 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1762,8 +1762,8 @@ automata. The following features are available:
(license license:gpl2+)))
(define-public joycond
- (let ((commit "f9a66914622514c13997c2bf7ec20fa98e9dfc1d")
- (revision "1"))
+ (let ((commit "9d1f5098b716681d087cca695ad714218a18d4e8")
+ (revision "2"))
(package
(name "joycond")
(version (git-version "0.1.0" revision commit))
@@ -1775,32 +1775,30 @@ automata. The following features are available:
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "07z86yp27vxc0b44jgvf1vpa69rh3wdvd1xbzcsrj3f32743pv5a"))))
+ (base32 "089qh20si3mwj945wjhg0nbain9cn49vwh2zqab6ws2cl0938gid"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;no test suite
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-bin-location
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "CMakeLists.txt"
- (("/lib/udev/rules.d")
- (string-append out "/lib/udev/rules.d"))
- (("/etc/systemd/system")
- (string-append out "/etc/systemd/system"))
- (("/etc/modules-load.d")
- (string-append out "/etc/modules-load.d"))
- (("/usr/bin")
- (string-append out "/bin")))))))))
+ (list #:tests? #f ;no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-bin-location
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("/lib/udev/rules.d")
+ (string-append #$output "/lib/udev/rules.d"))
+ (("/etc/systemd/system")
+ (string-append #$output "/etc/systemd/system"))
+ (("/etc/modules-load.d")
+ (string-append #$output "/etc/modules-load.d"))
+ (("/usr/bin")
+ (string-append #$output "/bin"))))))))
(native-inputs (list pkg-config))
- (inputs
- (list eudev libevdev))
+ (inputs (list eudev libevdev))
(home-page "https://github.com/DanielOgorchock/joycond")
(synopsis "Joy-Con controller daemon")
(description "This package provides a userspace daemon for the Nintendo
Joy-Con controllers.")
- (license license:gpl3))))
+ (license license:gpl3+))))
(define-public julius
(package