aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:08:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:24 +0200
commite84d051e71e6d6d74cc721a80eae2eaf9c7ab73b (patch)
treec819c05930792e99921775fb4d0eb00cd67528b2 /gnu/packages
parent6cabacd6ec3e9a1121e995143f0ae0374629f8e6 (diff)
downloadguix-e84d051e71e6d6d74cc721a80eae2eaf9c7ab73b.tar
guix-e84d051e71e6d6d74cc721a80eae2eaf9c7ab73b.tar.gz
gnu: Add trytond-account-cash-rounding.
* gnu/packages/tryton.scm (trytond-account-cash-rounding): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d47de2e2ae..53ec211926 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -265,6 +265,34 @@ of fixed assets.")
chart of account for Belgium.")
(license license:gpl3+)))
+(define-public trytond-account-cash-rounding
+ (package
+ (name "trytond-account-cash-rounding")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_cash_rounding" version))
+ (sha256
+ (base32 "15xl36929zgfw9rlwaqdqs5l4ijspfx8i060z6884p2nizhh69s5"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_cash_rounding"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-account-invoice" ,trytond-account-invoice)
+ ("trytond-purchase" ,trytond-purchase)
+ ("trytond-sale" ,trytond-sale)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-currency" ,trytond-currency)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-account-cash-rounding")
+ (synopsis "Tryton module to round cash amount")
+ (description "The @emph{Account Cash Rounding} Tryton module allows cash
+amounts to be rounded using the cash rounding factor of the currency.")
+ (license license:gpl3+)))
+
(define-public trytond-account-invoice
(package
(name "trytond-account-invoice")