aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-03-27 10:25:03 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:00 +0200
commitbd0b6a1b6812590ebfd68a407cc8051c7139774b (patch)
treeea70fb21861b661ffa8bbf25be677fa3d38b9527 /gnu/packages
parent9a2dca2e977f28727ab7e58bf9f114e293e748c0 (diff)
downloadguix-bd0b6a1b6812590ebfd68a407cc8051c7139774b.tar
guix-bd0b6a1b6812590ebfd68a407cc8051c7139774b.tar.gz
gnu: enchant: Update to 2.6.8.
* gnu/packages/enchant.scm (enchant): Update to 2.6.8. [native-inputs]: Add GROFF. Change-Id: I8c7d7e2b9124a55401c6623fd76eacc0878ad6e6 Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/enchant.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index 5efa0f2689..fa2b1fe170 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -25,6 +25,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages hunspell)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages man)
@@ -71,7 +72,7 @@ dictionaries.")
(define-public enchant
(package
(name "enchant")
- (version "2.2.15")
+ (version "2.6.8")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/AbiWord/enchant/releases"
@@ -79,7 +80,7 @@ dictionaries.")
version ".tar.gz"))
(sha256
(base32
- "00vcykbb7lxh51prvmsb62a06q18a6rlk9ba5a7g45c1awaj43rv"))))
+ "1bn7z8155czgzlnq2n4c915cl1vd3v95h1bghic3szy7c8q94rgm"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static"
@@ -92,6 +93,7 @@ dictionaries.")
(list glib))
(native-inputs
`(("glib:bin" ,glib "bin")
+ ("groff" ,groff)
("pkg-config" ,pkg-config)
("unittest-cpp" ,unittest-cpp)))
(synopsis "Multi-backend spell-checking library wrapper")