aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:11 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:02 +0000
commit8c5df06bd3cb823d26767fcf8ca80cfdbdeede4f (patch)
treedf0091efbf41a5f60ae059819ac9454256949c0a /gnu/packages
parent177a81537b7bb079a6ec2cdcf734658060589497 (diff)
downloadguix-8c5df06bd3cb823d26767fcf8ca80cfdbdeede4f.tar
guix-8c5df06bd3cb823d26767fcf8ca80cfdbdeede4f.tar.gz
gnu: Add ruby-thread-order.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 03b3191fc2..be431afe5b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6995,3 +6995,25 @@ https://github.com/flavorjones/loofah-activerecord).")
"Colorize printed text on ANSI terminals")
(home-page "https://github.com/sickill/rainbow")
(license license:expat)))
+
+(define-public ruby-thread-order
+ (package
+ (name "ruby-thread-order")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "thread_order" version))
+ (sha256
+ (base32
+ "1n8zs3m7na5jmpf0pw0z79vg0x0lfzajpynp28zb43l89l00qcfi"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "Test helper for ordering threaded code (does not depend on gems or stdlib, tested on 1.8.7 - 2.2, rbx, jruby).")
+ (description
+ "Test helper for ordering threaded code (does not depend on gems or stdlib, tested on 1.8.7 - 2.2, rbx, jruby).")
+ (home-page
+ "https://github.com/JoshCheek/thread_order")
+ (license license:expat)))