aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-09-12 19:21:24 +0200
committerChristopher Baines <mail@cbaines.net>2024-09-15 10:21:42 +0100
commit86764929f9929f7e0f0d9beeaa3125a6db719b16 (patch)
tree1450833491a3faec3229f0cdf3823cb198b408bf /gnu/packages
parent17c4c3449bae97943ddfca55d0b1f1a47034d15d (diff)
downloadguix-86764929f9929f7e0f0d9beeaa3125a6db719b16.tar
guix-86764929f9929f7e0f0d9beeaa3125a6db719b16.tar.gz
gnu: Remove python-msrest.
* gnu/packages/python-web.scm (python-msrest): Delete variable. Change-Id: Ic27ba6fe0e7f828327e98c99eabf536ea1cd544a Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index aea0f4c764..8b29f1cd93 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7960,53 +7960,6 @@ Features:
@end itemize")
(license license:expat)))
-(define-public python-msrest
- (package
- (name "python-msrest")
- (version "0.6.21")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "msrest" version))
- (sha256
- (base32 "1n389m3hcsyjskzimq4j71nyw9pjkrp0n5wg1q2c4bfwpv3inrkj"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest"
- "-k"
- ;; These attempt to connect to bing.com.
- (string-append
- "not test_basic_aiohttp"
- " and not test_basic_async_requests"
- " and not test_conf_async_requests"
- " and not test_conf_async_trio_requests"
- " and not test_basic_aiohttp"
- " and not test_basic_async_requests"
- " and not test_conf_async_requests"
- " and not test_conf_async_trio_requests"))))))))
- (propagated-inputs
- (list python-aiohttp
- python-certifi
- python-isodate
- python-requests
- python-requests-oauthlib))
- (native-inputs
- (list python-httpretty
- python-pytest
- python-pytest-aiohttp
- python-pytest-asyncio
- python-pytest-trio))
- (home-page "https://github.com/Azure/msrest-for-python")
- (synopsis "AutoRest swagger generator Python client runtime")
- (description "This package provides the runtime library @code{msrest} for
-AutoRest-generated Python clients.")
- (license license:expat)))
-
(define-public python-azure-nspkg
(package
(name "python-azure-nspkg")