aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-09 21:06:50 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 13:15:39 +0100
commit63e36f3a8b518af9c5d21ce4c69661322eec25bb (patch)
treeb30f065be8783350c319300d08751152ddf226ab /gnu/packages
parentb313bdc7e739244d88994976fcc2954d4ba10d49 (diff)
downloadguix-63e36f3a8b518af9c5d21ce4c69661322eec25bb.tar
guix-63e36f3a8b518af9c5d21ce4c69661322eec25bb.tar.gz
gnu: go-mvdan-cc-xurls: Swap inheritance.
These changes simplify packages by swapping inheritance from Golang module instead of the final binary for go-mvdan-cc-xurls and xurls variables. * gnu/packages/golang.scm (go-mvdan-cc-xurls): Simplify package. [arguments]: <#:phases>: Remove phases modification. (xurls): Inherit from go-mvdan-cc-xurls. Change-Id: I746e8c02afa8ea5341ae0043a05d43631ed1d032
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 9 insertions, 22 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d02f2d96e9..fafc05c8f9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7492,9 +7492,9 @@ That is, @code{gofumpt} is happy with a subset of the formats that
(native-inputs '())
(inputs '())))
-(define-public xurls
+(define-public go-mvdan-cc-xurls
(package
- (name "xurls")
+ (name "go-mvdan-cc-xurls")
(version "2.4.0")
(source (origin
(method git-fetch)
@@ -7507,15 +7507,7 @@ That is, @code{gofumpt} is happy with a subset of the formats that
"0b040nbk1vwlk1qljavh8w8fn2r243q700n6gr8j2asmnz0xq84p"))))
(build-system go-build-system)
(arguments
- `(#:import-path "mvdan.cc/xurls/v2"
- #:unpack-path "mvdan.cc/xurls/v2"
- #:phases (modify-phases %standard-phases
- (replace 'build
- (lambda arguments
- (apply (assoc-ref %standard-phases
- 'build)
- `(,@arguments #:import-path
- "mvdan.cc/xurls/v2/cmd/xurls")))))))
+ `(#:import-path "mvdan.cc/xurls/v2"))
(inputs (list go-golang-org-x-sync go-github-com-rogpeppe-go-internal))
(home-page "https://mvdan.cc/xurls/v2/")
(synopsis "Extracts URLs from text")
@@ -7524,19 +7516,14 @@ That is, @code{gofumpt} is happy with a subset of the formats that
be used as both a binary and a library.")
(license license:bsd-3)))
-(define-public go-mvdan-cc-xurls
+(define-public xurls
(package
- (inherit xurls)
- (name "go-mvdan-cc-xurls")
+ (inherit go-mvdan-cc-xurls)
+ (name "xurls")
(arguments
- `(#:import-path "mvdan.cc/xurls"
- #:tests? #f
- #:install-source? #t
- #:phases (modify-phases %standard-phases
- (delete 'build))))
- (propagated-inputs (package-inputs xurls))
- (native-inputs '())
- (inputs '())))
+ `(#:import-path "mvdan.cc/xurls/v2/cmd/xurls"
+ #:unpack-path "mvdan.cc/xurls/v2"
+ #:install-source? #f))))
(define-public go-github-com-davecgh-go-xdr
(package