aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-26 15:05:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-26 18:13:29 +0300
commit3171ff971c1c8d230e4a22091c9322e87b8b6c9d (patch)
treecbe252b00e415c701df9c952b6d456695ee7f7ad /gnu/packages
parent408a07775615ab8a13edb0de2ecbf75efdfe4c49 (diff)
downloadguix-3171ff971c1c8d230e4a22091c9322e87b8b6c9d.tar
guix-3171ff971c1c8d230e4a22091c9322e87b8b6c9d.tar.gz
gnu: classpath-jamvm-wrappers: Adjust wrapper for armhf-linux.
This fixes building icedtea-2 on armhf-linux. * gnu/packages/java-bootstrap.scm (classpath-jamvm-wrappers)[arguments]: Adjust the flags passed to jamvm in the wrapper script when building for armhf-linux. Change-Id: I68a47b0eec761b1be9126ac814693fba7fa7e56e
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/java-bootstrap.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/java-bootstrap.scm b/gnu/packages/java-bootstrap.scm
index 481d8cd075..645cbfa442 100644
--- a/gnu/packages/java-bootstrap.scm
+++ b/gnu/packages/java-bootstrap.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2022 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2020, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Andrius Štikonas <andrius@stikonas.eu>
@@ -492,10 +492,9 @@ the standard javac executable.")))
(for-each (lambda (tool)
(with-output-to-file (string-append bin tool)
(lambda _
- #$@(if (string-prefix? "armhf" (or (%current-system)
- (%current-target-system)))
+ #$@(if (target-arm32?)
`((format #t "#!~a/bin/sh
-~a/bin/jamvm -Xnocompact -classpath ~a/share/classpath/tools.zip \
+~a/bin/jamvm -classpath ~a/share/classpath/tools.zip \
gnu.classpath.tools.~a.~a $@"
bash jamvm classpath tool
(if (string=? "native2ascii" tool)