aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:52 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:37 +0200
commit52a6efc1ed86ae73080fcb30b62881426b8e39dd (patch)
treeb04a8b433d5dc365d68c5867e4b63790b57efed2 /gnu/packages/text-editors.scm
parenta2255a5b783fe3a1a5b7b1284f394d5ff1589fe3 (diff)
downloadguix-52a6efc1ed86ae73080fcb30b62881426b8e39dd.tar
guix-52a6efc1ed86ae73080fcb30b62881426b8e39dd.tar.gz
gnu: text-editors: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/text-editors.scm (vis)[inputs]: Add 'bash-minimal'. (jucipp)[inputs]: Likewise. (ghostwriter)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ic55d5602d0514029eba1f8d5313169570da3edb1
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9803f94793..6b35a7ea3b 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -201,7 +201,7 @@ extensions over the standard utility.")
(sha256
(base32 "1jsvg2lg3xqfgi79x08kx94mc34mh62ivca10vsci6fqsk68jbd0"))
(file-name (git-file-name "vis-test" version))))))
- (inputs (list lua ncurses libtermkey lua-lpeg tre))
+ (inputs (list bash-minimal lua ncurses libtermkey lua-lpeg tre))
(synopsis "Vim-like text editor")
(description
"Vis aims to be a modern, legacy free, simple yet efficient vim-like text
@@ -451,6 +451,7 @@ bindings and many of the powerful features of GNU Emacs.")
(list pkg-config xorg-server-for-tests))
(inputs
(list aspell
+ bash-minimal
boost
clang-11 ;XXX: must be the same version as Mesas LLVM
gtkmm-3
@@ -768,7 +769,8 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
(native-inputs
(list pkg-config qttools-5)) ; for lrelease
(inputs
- (list hunspell
+ (list bash-minimal
+ hunspell
qtbase-5
qtdeclarative-5
qtmultimedia-5