aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorLilah Tascheter <lilah@lunabee.space>2022-10-19 10:27:57 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:35 +0200
commita3ef89714f2f1afeca2d58ce686fbb84a5fca64c (patch)
tree7dfda520beaf21770d3409cf13a2d7cc33ce7b00 /gnu/packages/man.scm
parent1d16506c325c012d1d6328edbd5d1915729d01eb (diff)
downloadguix-a3ef89714f2f1afeca2d58ce686fbb84a5fca64c.tar
guix-a3ef89714f2f1afeca2d58ce686fbb84a5fca64c.tar.gz
gnu: man-pages-posix: Remove redundant manpage compression.
* gnu/packages/man.scm (man-pages-posix)[arguments]: Don't run build phase. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 780f6bf6d8..f4b995691c 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -374,11 +374,11 @@ Linux kernel and C library interfaces employed by user-space programs.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f
- ;; The compress-documentation phase doesn't pick up on our manpages as
- ;; its regex doesn't support trailing letters, so manually compress.
- #:make-flags ,#~(list (string-append "prefix=" #$output) "gz")
+ #:make-flags ,#~(list (string-append "prefix=" #$output))
#:license-file-regexp "POSIX-COPYRIGHT"
- #:phases (modify-phases %standard-phases (delete 'configure))))
+ ;; The build phase only compresses documentation, which we already do.
+ #:phases (modify-phases %standard-phases (delete 'configure)
+ (delete 'build))))
(home-page "https://www.kernel.org/doc/man-pages/")
(synopsis "Man pages from the POSIX.1-2013 standard")
(description