aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-23 16:35:42 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-23 17:05:18 +0100
commit48f5df83df17b4dec1d2273a4411f65996826dc1 (patch)
tree447ce68e3aa6e3c927453feb98c5c26fc78f18e0 /gnu/packages/golang.scm
parented907c7a29b1bdc143d148cccf7e5d1967fcb50b (diff)
downloadguix-48f5df83df17b4dec1d2273a4411f65996826dc1.tar
guix-48f5df83df17b4dec1d2273a4411f65996826dc1.tar.gz
gnu: go-github-com-muesli-reflow: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-muesli-reflow): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ie839050f776b764b034492292f7821266b953b1e
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8476bb43fb..34f867377f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6053,42 +6053,6 @@ matching and globbing with support for \"doublestar\" patterns.")
(list
#:import-path "github.com/bmatcuk/doublestar/v4"))))
-(define-public go-github-com-muesli-reflow
- (package
- (name "go-github-com-muesli-reflow")
- (version "0.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/muesli/reflow")
- (commit (string-append "v" version))))
- (file-name (git-file-name "go-github-com-muesli-reflow" version))
- (sha256
- (base32 "09zcz2cqdwgj1ilya5pqwndryk6lansn87x63fcm8j1xn74vd2ry"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/muesli/reflow"
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: Workaround for go-build-system's lack of Go modules
- ;; support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
- (propagated-inputs
- (list go-github-com-mattn-go-runewidth))
- (home-page "https://github.com/muesli/reflow/")
- (synopsis "Collection of methods helping to transform blocks of text")
- (description
- "This package provides a collection of ANSI-aware methods and io.Writers
-helping you to transform blocks of text.")
- (license license:expat)))
-
(define-public go-github-com-olekukonko-tablewriter
(package
(name "go-github-com-olekukonko-tablewriter")