aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 23:28:30 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 23:34:41 +0100
commit1e81c70e42c6e09c90c58119adea16d79409165a (patch)
tree9ae5d1c299db50a592fa21b6ae02ecf1cf51781b /gnu/packages/golang.scm
parentbd55b261093399128582d4b2b05bc68166dce0b7 (diff)
downloadguix-1e81c70e42c6e09c90c58119adea16d79409165a.tar
guix-1e81c70e42c6e09c90c58119adea16d79409165a.tar.gz
gnu: go-github-com-pelletier-go-toml: Remove input labels.
* gnu/packages/golang.scm (go-github-com-pelletier-go-toml): Remove input lables, swap [native-inputs] to [propagated-inputs] to simplify dependent packages inputs. Change-Id: Ibfa57fbe606ced8bf9f2bcfe4065bf94f84bc0fb
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a923fe6612..3e1814c20c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3590,10 +3590,10 @@ updating files, like @command{tail -f}.")
(build-system go-build-system)
(arguments
`(#:import-path "github.com/pelletier/go-toml"))
- (native-inputs
- `(("github.com/BurntSushi/toml" ,go-github-com-burntsushi-toml)
- ("github.com/davecgh/go-spew" ,go-github-com-davecgh-go-spew)
- ("gopkg.in/yaml.v2" ,go-gopkg-in-yaml-v2)))
+ (propagated-inputs
+ (list go-github-com-burntsushi-toml
+ go-github-com-davecgh-go-spew
+ go-gopkg-in-yaml-v2))
(home-page "https://github.com/pelletier/go-toml")
(synopsis "Go library for the TOML configuration language")
(description "Go library for the TOML configuration language")