aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 09:18:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:47 +0100
commit1edca36f334b081a10bfb30d043c951c9bb6ab18 (patch)
tree4c998a28732d2ceac514fbbc36db3188f9551a5b /gnu/packages/golang-build.scm
parent0bd0a2d16de314a93dbf2b3b0a7fb8fd8905a645 (diff)
downloadguix-1edca36f334b081a10bfb30d043c951c9bb6ab18.tar
guix-1edca36f334b081a10bfb30d043c951c9bb6ab18.tar.gz
gnu: go-github-com-yuin-goldmark: Enable all tests.
* gnu/packages/golang-build.scm (go-github-com-yuin-goldmark) [arguments]: <#:phases>: Use custom 'check phase. [description]: Start from the new line. Change-Id: I81c2c17c91460c77de385c38d9a3c3311656925a
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index d0a8971870..b7e7b6f14f 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -70,10 +70,21 @@
(base32 "01807xs8501cyhkrrgg6k9ghl9jrw6dp0ry9knygck48canckxs2"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/yuin/goldmark"))
+ (list
+ #:import-path "github.com/yuin/goldmark"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(home-page "https://github.com/yuin/goldmark/")
(synopsis "Markdown parser")
- (description "This package provides a markdown parser.")
+ (description
+ "This package provides a markdown parser.")
(license license:expat)))
(define-public go-golang-org-x-crypto