aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-27 03:55:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-27 03:55:24 +0200
commit9df24909e252980c2393d2baaa617c30db8c9dd8 (patch)
treea32bd0d0b993f05a51bd8f49993be99c0770262d /gnu/packages/games.scm
parentae40e02cd68d4e0ab10690bd4e59c698df472857 (diff)
parentfdabfdbf8d5e179b2726ae69ff8aec48b0504788 (diff)
downloadguix-9df24909e252980c2393d2baaa617c30db8c9dd8.tar
guix-9df24909e252980c2393d2baaa617c30db8c9dd8.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4c297005dc..60d885500c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2784,6 +2784,12 @@ fullscreen, use F5 or Alt+Enter.")
(lambda _
(substitute* "icons/Makefile.in"
(("\\$\\(INSTALL_DATA\\) \\$\\(srcdir\\)/warzone2100.appdata.xml.*") ""))
+ #t))
+ (add-after 'unpack 'patch-for-qt5.8
+ (lambda _
+ (substitute* "lib/widget/editbox.cpp"
+ (("== '\\\\0'")
+ "== QChar('\\0')"))
#t)))))
(native-inputs `(("pkg-config" ,pkg-config)
("unzip" ,unzip)
@@ -2797,7 +2803,8 @@ fullscreen, use F5 or Alt+Enter.")
("libxrandr" ,libxrandr)
("openal" ,openal)
("physfs" ,physfs)
- ("qt" ,qt)
+ ("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
("openssl" ,openssl)
("quesoglc" ,quesoglc)
("sdl2" ,sdl2)))