aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-15 10:57:23 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-15 10:57:31 +0100
commit953253eff32197863d223e5fece42b3c2440df01 (patch)
treeeb85f6b719322174f5dc504cac9de9829e1651e2 /gnu/packages/diffoscope.scm
parent2718616f77aace28b3962fef29b4e38b87a512ce (diff)
parent8e3831eb126478cad50588a0f3474667981b11ec (diff)
downloadguix-953253eff32197863d223e5fece42b3c2440df01.tar
guix-953253eff32197863d223e5fece42b3c2440df01.tar.gz
Merge remote-tracking branch 'savannah/master' into mesa-updates
Change-Id: I00980ec5dbd9d23ab076995bc79331d136424796
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 5bbb4f51e2..8106a6d258 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -52,6 +52,7 @@
#:use-module (gnu packages pascal)
#:use-module (gnu packages patchutils)
#:use-module (gnu packages pdf)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -74,7 +75,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "261")
+ (version "263")
(source
(origin
(method git-fetch)
@@ -83,7 +84,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0v56i2wyc4p843crl5b5w6j1awhp1a6xbfb92hm0pp8558f1h76i"))))
+ (base32 "1bq45gyn214hf9brnn5xlj9xvcg6p0yr8cc2p153f93pgzsyqlg4"))))
(build-system python-build-system)
(arguments
(list
@@ -138,6 +139,11 @@
(lambda _
;; This requires /sbin to be in $PATH.
(delete-file "tests/test_tools.py")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Increase verbosity of tests and provide a summary
+ (invoke "pytest" "-vv" "-r" "sxX"))))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -199,6 +205,7 @@
openssh
openssl
p7zip
+ perl
pgpdump
poppler
python-jsbeautifier