aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-20 17:36:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-20 17:36:56 +0100
commit7f69459aca16756f35f08049c64a1bd77d23f33e (patch)
tree1d267fb62feab89de5d97582672540cbaa37392c /gnu/packages/c.scm
parent4a82722a658220ec1e10f9f2d5d77407d38db90e (diff)
parentb1989c12501e880afab62d3ff961791906fef350 (diff)
downloadguix-7f69459aca16756f35f08049c64a1bd77d23f33e.tar
guix-7f69459aca16756f35f08049c64a1bd77d23f33e.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index d15d35e68d..b4e17cb53a 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,14 +35,14 @@
(define-public tcc
(package
(name "tcc") ;aka. "tinycc"
- (version "0.9.26")
+ (version "0.9.27")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/tinycc/tcc-"
version ".tar.bz2"))
(sha256
(base32
- "0wbdbdq6090ayw8bxnbikiv989kykff3m5rzbia05hrnwhd707jj"))))
+ "177bdhwzrnqgyrdv1dwvpd04fcxj68s5pm1dzwny6359ziway8yy"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)
("texinfo" ,texinfo)))
@@ -71,6 +72,8 @@
written in C. It supports ANSI C with GNU and extensions and most of the C99
standard.")
(home-page "http://www.tinycc.org/")
+ ;; An attempt to re-licence tcc under the Expat licence is underway but not
+ ;; (if ever) complete. See the RELICENSING file for more information.
(license license:lgpl2.1+)))
(define-public tcc-wrapper