aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-27 23:19:49 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-27 23:19:49 +0200
commitaf018f5e0a1b7c67e9f40ca68929bd35b94206d3 (patch)
tree8c3efe66f8ac1f6178357937c0a41c6f5ff8f0f8 /configure.ac
parentd84a7be6675bd647931d8eff9134d00dd5a6bd58 (diff)
parent35066aa596931ef84922298c2760ceba69940cd1 (diff)
downloadguix-af018f5e0a1b7c67e9f40ca68929bd35b94206d3.tar
guix-af018f5e0a1b7c67e9f40ca68929bd35b94206d3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 26 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 05e0370e6b..d65211779c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,19 +116,44 @@ AC_ARG_WITH([libgcrypt-prefix],
yes|no)
LIBGCRYPT="libgcrypt"
LIBGCRYPT_PREFIX="no"
+ LIBGCRYPT_LIBDIR="no"
;;
*)
LIBGCRYPT="$withval/lib/libgcrypt"
LIBGCRYPT_PREFIX="$withval"
+ LIBGCRYPT_LIBDIR="$withval/lib"
;;
esac],
- [LIBGCRYPT="libgcrypt"])
+ [LIBGCRYPT="libgcrypt"
+ LIBGCRYPT_PREFIX="no"
+ LIBGCRYPT_LIBDIR="no"])
+
+AC_ARG_WITH([libgcrypt-libdir],
+ [AS_HELP_STRING([--with-libgcrypt-libdir=DIR],
+ [search for GNU libgcrypt's shared library in DIR])],
+ [case "$withval" in
+ yes|no)
+ LIBGCRYPT="libgcrypt"
+ LIBGCRYPT_LIBDIR="no"
+ ;;
+ *)
+ LIBGCRYPT="$withval/libgcrypt"
+ LIBGCRYPT_LIBDIR="$withval"
+ ;;
+ esac],
+ [if test "x$LIBGCRYPT" = x; then
+ LIBGCRYPT="libgcrypt"
+ fi
+ if test "x$LIBGCRYPT_LIBDIR" = x; then
+ LIBGCRYPT_LIBDIR="no"
+ fi])
dnl Library name suitable for `dynamic-link'.
AC_MSG_CHECKING([for libgcrypt shared library name])
AC_MSG_RESULT([$LIBGCRYPT])
AC_SUBST([LIBGCRYPT])
AC_SUBST([LIBGCRYPT_PREFIX])
+AC_SUBST([LIBGCRYPT_LIBDIR])
GUIX_ASSERT_LIBGCRYPT_USABLE