aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-26 13:42:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-26 14:08:24 +0200
commitf87d594238fb86dab8344a411fe62681ba0715b7 (patch)
tree08a1950850f9c87fcdc3a9e819239d58949b9e5c
parent260eae789369170cad76ac0ef94fe9ae5af44ce0 (diff)
downloadguix-f87d594238fb86dab8344a411fe62681ba0715b7.tar
guix-f87d594238fb86dab8344a411fe62681ba0715b7.tar.gz
gnu: boinc-server: Fix build.
* gnu/packages/distributed.scm (boinc-server)[inputs]: Replace openssl with openssl-1.0, mariadb with mariadb:dev.
-rw-r--r--gnu/packages/distributed.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/distributed.scm b/gnu/packages/distributed.scm
index c5207aace4..a65ea72aa9 100644
--- a/gnu/packages/distributed.scm
+++ b/gnu/packages/distributed.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Brant Gardner <brantcgardner@brantware.com>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -88,9 +89,9 @@ resources). It supports virtualized, parallel, and GPU-based applications.")
#:tests? #f)) ; FIXME: Looks like bad test syntax in the
; source package, 2 tests fail. Disable for
; now.
- (inputs `(("openssl" ,openssl)
+ (inputs `(("openssl" ,openssl-1.0)
("curl" ,curl)
- ("mariadb" ,mariadb)
+ ("mariadb:dev" ,mariadb "dev")
("zlib" ,zlib)))
(propagated-inputs `(("python" ,python-wrapper)
("perl" ,perl)))))