aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-31 14:57:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:45:50 +0300
commited13824d612b0245b3be533f998efd5b409bda95 (patch)
treed93f6f6702e208c67ea0e4f374bc255205ff3744
parent3e7f69f8556191d920c762480aec09d38be3ee66 (diff)
downloadguix-ed13824d612b0245b3be533f998efd5b409bda95.tar
guix-ed13824d612b0245b3be533f998efd5b409bda95.tar.gz
gnu: Add rust-lazy-regex-3.
* gnu/packages/crates-io.scm (rust-lazy-regex-3): New variable. Change-Id: I166ddb4aea5d4a698a490734669e83e9444cd061
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7b05bee526..473b346a17 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -36069,6 +36069,29 @@ generated by LALRPOP.")
"This crate provides simple methods to cast from and into byte arrays.")
(license license:boost1.0)))
+(define-public rust-lazy-regex-3
+ (package
+ (name "rust-lazy-regex")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lazy-regex" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0k3sjdcr13j119kgz1h7f1k2mnl787ig9ag436ymipxgjm2vw4jx"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-lazy-regex-proc-macros" ,rust-lazy-regex-proc-macros-3)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-regex-lite" ,rust-regex-lite-0.1))))
+ (home-page "https://github.com/Canop/lazy-regex")
+ (synopsis "Lazy static regular expressions checked at compile time")
+ (description "Lazy static regular expressions checked at compile time.")
+ (license license:expat)))
+
(define-public rust-lazy-regex-proc-macros-3
(package
(name "rust-lazy-regex-proc-macros")