aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-03-27 18:39:28 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-03-27 18:40:21 +0100
commiteb5341c2353ef54ef8b227ae8e50aa5736a40ddc (patch)
tree6e3a4f749a7e32c203f27c5467ad98d5258e8b0c
parentbc3fda5d2b97526cee7d1b127e95067521dfb99e (diff)
downloadguix-eb5341c2353ef54ef8b227ae8e50aa5736a40ddc.tar
guix-eb5341c2353ef54ef8b227ae8e50aa5736a40ddc.tar.gz
gnu: Add trivial-package-local-nicknames.
* gnu/packages/lisp-xyz.scm (cl-trivial-package-local-nicknames, sbcl-trivial-package-local-nicknames): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 043c219e5e..f39dd170a9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11250,3 +11250,28 @@ If features:
(define-public cl-sycamore
(sbcl-package->cl-source-package sbcl-sycamore))
+
+(define-public sbcl-trivial-package-local-nicknames
+ (package
+ (name "sbcl-trivial-package-local-nicknames")
+ (version "0.2")
+ (home-page "https://github.com/phoe/trivial-package-local-nicknames")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit "16b7ad4c2b120f50da65154191f468ea5598460e")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18qc27xkjzdcqrilpk3pm7djldwq5rm3ggd5h9cr8hqcd54i2fqg"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "Common Lisp compatibility library for package local nicknames")
+ (description
+ "This library is a portable compatibility layer around package local nicknames (PLN).
+This was done so there is a portability library for the PLN API not included
+in DEFPACKAGE.")
+ (license license:unlicense)))
+
+(define-public cl-trivial-package-local-nicknames
+ (sbcl-package->cl-source-package sbcl-trivial-package-local-nicknames))