aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:22:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:55 +0200
commitd4c7d97764e863a0258df2d6dded4502475678e4 (patch)
tree627e6bb7ff8df4e25d5c517122209ec30bc8f23e
parentb355c4272d93a1b2708fe5e723dc72792bfaf64e (diff)
downloadguix-d4c7d97764e863a0258df2d6dded4502475678e4.tar
guix-d4c7d97764e863a0258df2d6dded4502475678e4.tar.gz
gnu: Add texlive-nwafuthesis.
* gnu/packages/tex.scm (texlive-nwafuthesis): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 46461bcf73..eb5d0fc511 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23456,6 +23456,31 @@ mathematical function values.")
of fonts, designed by Vernon Adams.")
(license (list license:silofl1.1 license:lppl))))
+(define-public texlive-nwafuthesis
+ (package
+ (name "texlive-nwafuthesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/nwafuthesis/"
+ "source/latex/nwafuthesis/"
+ "tex/latex/nwafuthesis/")
+ (base32
+ "001axgdkvkcwfhzg9iw5sgahxh54sp6imi2b442li8f6n5c717lx")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:tex-format "xetex" #:build-targets #~(list "nwafuthesis.dtx")))
+ (native-inputs (list texlive-xetex))
+ (home-page "https://ctan.org/pkg/nwafuthesis")
+ (synopsis "Thesis template package for Northwest A&F University, China")
+ (description
+ "This template supports doctoral and master dissertations and
+undergraduate theses in Chinese. It aims to create a simple interface,
+a normative format, as well as a hackable class for the users. At present, it
+only supports XeTeX and LuaTeX engines.")
+ (license license:lppl1.3c)))
+
(define-public texlive-objectz
(package
(name "texlive-objectz")