aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-24 19:49:02 +0300
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:01 +0200
commitc39104dbe1b9ef697be0688093029eb9f27d1184 (patch)
tree995e4c3f0a410063b3be677d8c071bc057ab4414
parent5d9157c4526401c747c1b9627aa5b5bb481e75cc (diff)
downloadguix-c39104dbe1b9ef697be0688093029eb9f27d1184.tar
guix-c39104dbe1b9ef697be0688093029eb9f27d1184.tar.gz
gnu: tslib: Update to 1.23.
* gnu/packages/video.scm (tslib): Update to 1.23. [source]: Download using release tarball. [native-inputs]: Remove autoconf, automake, libtool. Change-Id: Ib3d33cb33eba39f8c273b8737b39b54f6c8f7819
-rw-r--r--gnu/packages/video.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3da7a29c82..0ff47db3f9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -732,26 +732,20 @@ other software.")
(define-public tslib
(package
(name "tslib")
- (version "1.22")
+ (version "1.23")
(source
(origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/libts/tslib")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://github.com/libts/tslib/releases/download/"
+ version "/tslib-" version ".tar.xz"))
(sha256
- (base32 "197p6vy539wvfrv23agbvmay4rjya1jnisi46llm0nx4cvqh48by"))))
+ (base32 "1b0xk746dcf72rd8xkxnjfn3axc57y6ahmg95wgj01l0sia9lj4v"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "tests"
- #:configure-flags
- (list "--with-sdl2")))
- (native-inputs
- (list autoconf automake libtool pkg-config))
- (inputs
- `(("sdl2" ,sdl2)))
+ #:configure-flags (list "--with-sdl2")))
+ (native-inputs (list pkg-config))
+ (inputs (list sdl2))
(synopsis "Touchscreen access library")
(description "TSLib is a cross-platform library that provides access to
touchscreen devices and the ability to apply filters to their input events.")