aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 07:18:47 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:25 +0200
commitc0b05e765fb991de9e04a27f5404728d16fa2180 (patch)
tree1e27f3224b03c8ef8a8dd7e5446162a77daaa801
parent9a9f1a5aab5e9b82ed75f821cf740c8dbbd0a820 (diff)
downloadguix-c0b05e765fb991de9e04a27f5404728d16fa2180.tar
guix-c0b05e765fb991de9e04a27f5404728d16fa2180.tar.gz
gnu: Add texlive-makeindex-bin.
* gnu/packages/tex.scm (texlive-makeindex-bin): New variable. (texlive-makeindex)[propagated-inputs]: Add TEXLIVE-MAKEINDEX-BIN. Change-Id: I00a5600d3260696c3c67f89902e7f69ea98ba30d
-rw-r--r--gnu/packages/tex.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 968c0d9319..c44a863587 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -54681,6 +54681,7 @@ always (re)defines a command. There is also @code{\\makeenvironment} and
"0m01m0x1kf10yvzxgrkvpic0amsr0g6q2r2wsg5f4ngybq4y9gyi")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-makeindex-bin))
(home-page "https://ctan.org/pkg/makeindexk")
(synopsis "Makeindex development sources")
(description
@@ -54688,6 +54689,52 @@ always (re)defines a command. There is also @code{\\makeenvironment} and
(license
(license:fsf-free "https://mirrors.ctan.org/indexing/makeindex/COPYING"))))
+(define-public texlive-makeindex-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-makeindex-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "texk" '("makeindexk" "tests"))
+ (delete-other-directories "utils" '())))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-makeindexk" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "texk/makeindexk"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/makeindexk"
+ (invoke "make" "install"))))))))
+ (native-inputs (list perl pkg-config))
+ (inputs (list texlive-libkpathsea))
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-makeindex))
+ (synopsis "Binary for @code{texlive-makeindex}")
+ (description
+ "This package provides the binary for @code{texlive-makeindex}.")
+ (license (package-license texlive-makeindex))))
+
(define-public texlive-marginfix
(package
(name "texlive-marginfix")