aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorspencerpeters <spencerpeters@protonmail.com>2024-08-11 21:25:32 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 00:33:33 +0100
commita84f26f0afff1cf28b7b0edca8e1ff4e0389d961 (patch)
treef8eb27619c20f9b9434451def112edbe2e1110f7
parentdd81dcecde26120853dfc93e26af3b852aa44313 (diff)
downloadguix-a84f26f0afff1cf28b7b0edca8e1ff4e0389d961.tar
guix-a84f26f0afff1cf28b7b0edca8e1ff4e0389d961.tar.gz
gnu: Add go-go-senan-xyz-flagconf
I've fixed the inputs for go-go-senan-xyz-flagconf and cliphist and I've updated the build-system arguments as well as the [synopsis] and [description] fields for cliphist. I believe the formatting issues were caused by my email client--hopefully this time it doesn't mess up the indentation again. Best, Spencer * gnu/packages/golang-xyz.scm (go-go-senan-xyz-flagconf): New variable. Change-Id: I3edcda63ca09e1370be4da8c6926bacde5d66cbf Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index becdef319b..b2079e1aa1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Luis Higino <luishenriquegh2701@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6421,6 +6422,32 @@ reliable database for projects that don't require a full database server such as
Postgres or MySQL.")
(license license:expat)))
+(define-public go-go-senan-xyz-flagconf
+ (package
+ (name "go-go-senan-xyz-flagconf")
+ (version "0.1.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sentriz/flagconf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rms7hj1cdi5gfyhf1am1f8c4lq9ll4ashqi87yc6aq93gqgkag0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "go.senan.xyz/flagconf"))
+ (propagated-inputs
+ (list go-github-com-rogpeppe-go-internal))
+ (home-page "https://go.senan.xyz/flagconf")
+ (synopsis "Extensions to Go's flag package")
+ (description
+ "Flagconf provides extensions to Go's flag package to support prefixed
+environment variables and a simple config file format.")
+ (license license:expat)))
+
(define-public go-go-uber-org-atomic
(package
(name "go-go-uber-org-atomic")