aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:33:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:46 +0200
commit8f0bce32e71183648b30ab409726e268bec53403 (patch)
treecd1f13d9dd21a216323df55856aeaa982cee5c75
parent4389c1b32a6fa4a1fdbdc73bb76616170636f0a4 (diff)
downloadguix-8f0bce32e71183648b30ab409726e268bec53403.tar
guix-8f0bce32e71183648b30ab409726e268bec53403.tar.gz
gnu: Add texlive-notes2bib.
* gnu/packages/tex.scm (texlive-notes2bib): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0510548116..ad496bd136 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14080,6 +14080,29 @@ implements the @code{\\Next}, @code{\\NNext}, @code{\\Last}, and
commands from the @code{expex} package.")
(license license:lppl1.3+)))
+(define-public texlive-notes2bib
+ (package
+ (name "texlive-notes2bib")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/notes2bib/"
+ "source/latex/notes2bib/"
+ "tex/latex/notes2bib/")
+ (base32
+ "0d51xy7hlwdl752yl1sfr7f6r77j41nkpj1mf1l7pycn5nlnii79")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/notes2bib")
+ (synopsis "Integrating notes into the bibliography")
+ (description
+ "The package defines a new type of note, @code{bibnote}, which will
+always be added to the bibliography. The package allows footnotes and
+endnotes to be moved into the bibliography in the same way. The package can
+be used with @code{natbib} and BibLaTeX as well as plain LaTeX citations.
+Both sorted and unsorted bibliography styles are supported.")
+ (license license:lppl1.3c)))
+
(define-public texlive-nuc
(package
(name "texlive-nuc")