aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:32:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:45 +0200
commit7d4d8932e6d20f9b6712feae99a0591c2c89a419 (patch)
treeecd30c01933508e3074579e6a55c5ce1beb6413b
parentddb1bf22f1fc8ce442cdc87a31836f3109bebc45 (diff)
downloadguix-7d4d8932e6d20f9b6712feae99a0591c2c89a419.tar
guix-7d4d8932e6d20f9b6712feae99a0591c2c89a419.tar.gz
gnu: Add texlive-newcastle-bst.
* gnu/packages/tex.scm (texlive-newcastle-bst): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c302728629..cdeea88113 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13966,6 +13966,27 @@ environments for quickly creating nice mathematical documents.")
"This LaTeX package provides automatic definite articles for Hungarian.")
(license license:lppl1.3+)))
+(define-public texlive-newcastle-bst
+ (package
+ (name "texlive-newcastle-bst")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/newcastle-bst/"
+ "doc/bibtex/newcastle-bst/")
+ (base32
+ "0q5mwwiwf6pvlk6xbvrc6rfm87qrkpp7nba4qgdagjkdrn0hs4jz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/newcastle-bst")
+ (synopsis
+ "BibTeX style following Harvard at Newcastle style recommendations")
+ (description
+ "This package provides a BibTeX style to format reference lists in the
+Harvard at Newcastle style recommended by Newcastle University. It should be
+used alongside @code{natbib} for citations.")
+ (license license:lppl1.3c)))
+
(define-public texlive-nicematrix
(package
(name "texlive-nicematrix")