aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-08-04 22:16:01 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-06 11:46:26 +0200
commit77f59d1458686244a05eec4754af46f89af9a9be (patch)
tree6aefaa643517661e4e257b2c6ce27a0414c915c6
parente4b99a7918cb0da2661f81f60de441e5a92131ef (diff)
downloadguix-77f59d1458686244a05eec4754af46f89af9a9be.tar
guix-77f59d1458686244a05eec4754af46f89af9a9be.tar.gz
gnu: python-torchmetrics: Update to 1.4.1.
* gnu/packages/machine-learning.scm (python-torchmetrics): Update to 1.4.1. [source]: Switch to GitHub repository. [arguments]: New field. [propagated-inputs]: Add python-lightning-utilities. [home-page]: Update URL.
-rw-r--r--gnu/packages/machine-learning.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 6aff146e42..22f5a8e4df 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5281,17 +5281,25 @@ PyTorch code to decouple the science from the engineering.")
(define-public python-torchmetrics
(package
(name "python-torchmetrics")
- (version "0.11.4")
+ (version "1.4.1")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "torchmetrics" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lightning-AI/torchmetrics")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "150lcy6c20n42rwxl4d3m1b8s4js9ddds5wh3685vmjdnha5mr0z"))))
+ "0371kx2fpp46rlhzkafa7397kp1lirgykpzk9g12kxsqypb67v1l"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Tests require many additional dependencies
+ #:tests? #f))
(propagated-inputs
(list python-numpy python-packaging python-pytorch
- python-typing-extensions))
+ python-typing-extensions
+ python-lightning-utilities))
(native-inputs
(list python-cloudpickle
python-coverage
@@ -5311,7 +5319,7 @@ PyTorch code to decouple the science from the engineering.")
python-scipy
python-types-protobuf
python-types-setuptools))
- (home-page "https://github.com/Lightning-AI/metrics")
+ (home-page "https://github.com/Lightning-AI/torchmetrics")
(synopsis "Machine learning metrics for PyTorch applications")
(description "TorchMetrics is a collection of 100+ PyTorch metrics
implementations and an easy-to-use API to create custom metrics. It offers: