aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-08-05 11:01:37 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:42 +0100
commit60cd7def8543d4f88ef2f35b2cea61b4d497b660 (patch)
tree5269f971b93dede441eac43aaac8a1f04b76356f
parent083a3aefb0006cd4604856eab8a6dff250c783b0 (diff)
downloadguix-60cd7def8543d4f88ef2f35b2cea61b4d497b660.tar
guix-60cd7def8543d4f88ef2f35b2cea61b4d497b660.tar.gz
gnu: Add go-github-com-ianlancetaylor-demangle.
* gnu/packages/golang-xyz.scm (go-github-com-ianlancetaylor-demangle): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I3db163b9d32eff30539d81556309ec554bc3dbe6
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b1836da249..d55bdf0be1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1491,6 +1491,34 @@ storing only one copy of each unique string in memory. All functions may be
called concurrently with themselves and each other.")
(license license:expat)))
+(define-public go-github-com-ianlancetaylor-demangle
+ ;; No release, see <https://github.com/ianlancetaylor/demangle/issues/21>.
+ (package
+ (name "go-github-com-ianlancetaylor-demangle")
+ (version "0.0.0-20230524184225-eabc099b10ab")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ianlancetaylor/demangle")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pvlg1adp50hnw8dz7il473xb197ixirg26cy5hj3ngb4qlajwvc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ianlancetaylor/demangle"))
+ (home-page "https://github.com/ianlancetaylor/demangle")
+ (synopsis "Symbol name demangler written in Go")
+ (description
+ "This package defines functions that demangle GCC/LLVM C++ and Rust
+symbol names. This package recognizes names that were mangled according to
+the C++ ABI defined at https://codesourcery.com/cxx-abi/ and the
+@url{https://rust-lang.github.io/rfcs/2603-rust-symbol-name-mangling-v0.html,Rust
+ABI}.")
+ (license license:bsd-3)))
+
(define-public go-github-com-k0kubun-pp
(package
(name "go-github-com-k0kubun-pp")