aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:40:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:49 +0200
commit5c852f28dcef401252ea988efb04a5ca5f564205 (patch)
treea5d6159060babfbab9c78b445f238fd2d8334cd4
parent405d91bc0f026dfa8a7df46e602b4d21477767e6 (diff)
downloadguix-5c852f28dcef401252ea988efb04a5ca5f564205.tar
guix-5c852f28dcef401252ea988efb04a5ca5f564205.tar.gz
gnu: Add texlive-urlbst.
* gnu/packages/tex.scm (texlive-urlbst): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 00b6b9a1d0..e61958be6b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17878,6 +17878,30 @@ to define new units and changes the output concerning to the surrounding font
settings.")
(license license:lppl)))
+(define-public texlive-urlbst
+ (package
+ (name "texlive-urlbst")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/urlbst/" "doc/bibtex/urlbst/"
+ "scripts/urlbst/" "source/bibtex/urlbst/")
+ (base32
+ "0sfs2ybkfcqy8w0wdni3aakpnmk60zkmnlc55xskyzzh4yc69qi7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "urlbst")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/urlbst")
+ (synopsis "Web support for BibTeX")
+ (description
+ "This package supports a new BibTeX @code{webpage} entry type and @code{url},
+@code{lastchecked}, and @code{eprint} and @code{DOI} fields. The Perl script
+@command{urlbst} can be used to add this support to an arbitrary @file{.bst}
+file which has a reasonably conventional structure. The result is meant to be
+robust rather than pretty.")
+ (license (list license:gpl2 license:lppl))))
+
(define-public texlive-velthuis
(package
(name "texlive-velthuis")