aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-31 14:37:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:45:33 +0300
commit45829a0fb02394ecc60785d92064e3f349389bc8 (patch)
treecf7f30ef381769225ff54fbe28c010356f4d8a5a
parentaa7e62b6ea8cd1daf9b9005cb6dfb394fc518cb4 (diff)
downloadguix-45829a0fb02394ecc60785d92064e3f349389bc8.tar
guix-45829a0fb02394ecc60785d92064e3f349389bc8.tar.gz
gnu: Add rust-ufmt-0.2.
* gnu/packages/crates-io.scm (rust-ufmt-0.2): New variable. (rust-ufmt-0.1): Inherit from rust-ufmt-0.2. Change-Id: I444e6792d588a0ff4af30747eceb878913640f14
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 24 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7401924f70..7fc9a207d4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83578,8 +83578,31 @@ with the Unicode character database.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-ufmt-0.2
+ (package
+ (name "rust-ufmt")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ufmt" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "17dbpq5r09mcpalra2hmpgb2ly282s6xjsb4il8fjmrbq1p88r0s"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; method cannot be called on `String` due to unsatisfied trait bounds
+ #:cargo-inputs (("rust-ufmt-macros" ,rust-ufmt-macros-0.3)
+ ("rust-ufmt-write" ,rust-ufmt-write-0.1))))
+ (home-page "https://github.com/japaric/ufmt")
+ (synopsis "Faster and panic-free alternative to @code{core::fmt}")
+ (description "This package provides a (6-40x) smaller, (2-9x) faster and
+panic-free alternative to @code{core::fmt}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-ufmt-0.1
(package
+ (inherit rust-ufmt-0.2)
(name "rust-ufmt")
(version "0.1.2")
(source
@@ -83590,19 +83613,13 @@ with the Unicode character database.")
(sha256
(base32
"1pbc0gcfi7m21ly00x460pv1k2h12zb184f7wpcckpqj6g3c1lri"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-test-flags
'("--release" "--lib" "--bins" "--tests")
#:cargo-inputs
(("rust-proc-macro-hack" ,rust-proc-macro-hack-0.5)
("rust-ufmt-macros" ,rust-ufmt-macros-0.2)
- ("rust-ufmt-write" ,rust-ufmt-write-0.1))))
- (home-page "https://github.com/japaric/ufmt")
- (synopsis "Faster and panic-free alternative to @code{core::fmt}")
- (description "This package provides a (6-40x) smaller, (2-9x) faster and
-panic-free alternative to @code{core::fmt}.")
- (license (list license:expat license:asl2.0))))
+ ("rust-ufmt-write" ,rust-ufmt-write-0.1))))))
(define-public rust-ufmt-macros-0.3
(package