aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:02:11 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commitbd7a82f59b963460a585615fa5b049e545c251e7 (patch)
treedec6858b7efaa284a9d9864db05a87b46318c247
parentfbe0e28111a91b1697cc352f2f21bd5e2117a595 (diff)
downloadguix-bd7a82f59b963460a585615fa5b049e545c251e7.tar
guix-bd7a82f59b963460a585615fa5b049e545c251e7.tar.gz
gnu: Add ruby-listen-3.0.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch16
-rw-r--r--gnu/packages/ruby.scm18
3 files changed, 35 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index dfca8deb32..85322821cf 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1085,6 +1085,7 @@ dist_patch_DATA = \
%D%/packages/patches/ruby-rspec-its-remove-rspec-gemspec.patch\
%D%/packages/patches/ruby-therubyracer-fix-gemspec.patch \
%D%/packages/patches/ruby-listen-patch-gemspec.patch \
+ %D%/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch \
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
%D%/packages/patches/rxvt-unicode-escape-sequences.patch \
%D%/packages/patches/scheme48-tests.patch \
diff --git a/gnu/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch b/gnu/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch
new file mode 100644
index 0000000000..e870c060a5
--- /dev/null
+++ b/gnu/packages/patches/ruby-listen-3.0.8-patch-gemspec.patch
@@ -0,0 +1,16 @@
+diff --git a/listen.gemspec b/listen.gemspec
+index ee1316e..067dca3 100644
+--- a/listen.gemspec
++++ b/listen.gemspec
+@@ -14,9 +14,8 @@ Gem::Specification.new do |s|
+ s.description = 'The Listen gem listens to file modifications and '\
+ 'notifies you about the changes. Works everywhere!'
+
+- s.files = `git ls-files -z`.split("\x0").select do |f|
+- /^(?:bin|lib)\// =~ f
+- end + %w(CHANGELOG.md CONTRIBUTING.md LICENSE.txt README.md)
++ s.files = `find bin lib -type f |sort`.split("\n") +
++ %w(CHANGELOG.md CONTRIBUTING.md LICENSE.txt README.md)
+
+ s.test_files = []
+ s.executable = 'listen'
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1437054d78..4b12ada5d4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7567,3 +7567,21 @@ https://github.com/flavorjones/loofah-activerecord).")
"The Listen gem listens to file modifications and notifies you about the changes. Works everywhere!")
(home-page "https://github.com/guard/listen")
(license license:expat)))
+
+(define-public ruby-listen-3.0
+ (package
+ (inherit ruby-listen)
+ (name "ruby-listen")
+ (version "3.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The gem does not include a Rakefile, so we fetch the tarball from
+ ;; Github.
+ (uri (string-append "https://github.com/guard/listen/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06cy038xlbi8hcr9nv0c9wvafi7s3d05sdc7ydkv8qndi9bs68l3"))
+ (patches (search-patches "ruby-listen-3.0.8-patch-gemspec.patch"))))))