aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:02:25 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commitb788e3e3b62aebc1713c3dfed81dffbe26eb35cf (patch)
tree8d1fda56270dc734cf605a1c669fee58a39b95f9
parentbd7a82f59b963460a585615fa5b049e545c251e7 (diff)
downloadguix-b788e3e3b62aebc1713c3dfed81dffbe26eb35cf.tar
guix-b788e3e3b62aebc1713c3dfed81dffbe26eb35cf.tar.gz
gnu: Add ruby-ruby-dep.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4b12ada5d4..cd36e01740 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7585,3 +7585,24 @@ https://github.com/flavorjones/loofah-activerecord).")
(base32
"06cy038xlbi8hcr9nv0c9wvafi7s3d05sdc7ydkv8qndi9bs68l3"))
(patches (search-patches "ruby-listen-3.0.8-patch-gemspec.patch"))))))
+
+(define-public ruby-ruby-dep
+(package
+ (name "ruby-ruby-dep")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby_dep" version))
+ (sha256
+ (base32
+ "12i57gpy0gmkwnd7l6xdjpfw9bygxmgwx4hjwgg4mca2jr7d3g47"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Do not test to avoid circular dependency with gem_isolator.
+ (synopsis
+ "Creates a version constraint of supported Rubies,suitable for a gemspec file")
+ (description
+ "Creates a version constraint of supported Rubies,suitable for a gemspec file")
+ (home-page "https://github.com/e2/ruby_dep")
+ (license license:expat)))