aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:56:01 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commita6a3c4a5fc2dc64aa234acd31140cd3e6859ac9d (patch)
treee133b2bb0baddf48eb0970a26beadea3f2503751
parent46c4c888cba06e507a24349a94c2d1208abddd91 (diff)
downloadguix-a6a3c4a5fc2dc64aa234acd31140cd3e6859ac9d.tar
guix-a6a3c4a5fc2dc64aa234acd31140cd3e6859ac9d.tar.gz
gnu: Add ruby-rr.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3ed74214b2..ae8a0a9dd6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6863,3 +6863,27 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"https://github.com/flavorjones/loofah")
(license license:expat)))
+
+(define-public ruby-rr
+(package
+ (name "ruby-rr")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rr" version))
+ (sha256
+ (base32
+ "0b05ycaw17wbxzycv1wvzklpqjnmi0dqy01igcl5jfmy1ydky66r"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; test files not included
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "RR is a test double framework that features a rich selection of double techniques and a terse syntax.")
+ (description
+ "RR is a test double framework that features a rich selection of double techniques and a terse syntax.")
+ (home-page "https://rr.github.io/rr")
+ (license license:expat)))