aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:00:55 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit93c774cbf54ccf78885438e59b27fe81cb03c6b9 (patch)
treee482df1f80597e066539cb8790ae5fe792d0d766
parent11f993514e9b35bcfeda7403cae839edf1f05a43 (diff)
downloadguix-93c774cbf54ccf78885438e59b27fe81cb03c6b9.tar
guix-93c774cbf54ccf78885438e59b27fe81cb03c6b9.tar.gz
gnu: Add ruby-redjs.
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cb3e24b5a1..46fbbada97 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7363,3 +7363,35 @@ https://github.com/flavorjones/loofah-activerecord).")
"A Ruby implementation of the Coveralls API.")
(home-page "https://coveralls.io")
(license license:expat)))
+
+(define-public ruby-redjs
+ ;; There are no releases on rubygems and the last git commit was in 2012, so
+ ;; we package that.
+ (let ((commit "0d844f066666f967a78b20beb164c52d9ac3f5ca"))
+ (package
+ (name "ruby-redjs")
+ (version (string-append "0.4.6-1." (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cowboyd/redjs.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0cl3543xnzfn5qvlwjl2g1gg0jm6mfa75ag9qh89pfay7b0mxz7i"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'replace-git-ls-files
+ (lambda _
+ (substitute* "redjs.gemspec"
+ (("git ls-files") "find . -type f |sort"))
+ #t)))))
+ (synopsis "")
+ (description
+ "")
+ (home-page "")
+ (license license:expat)))) ;?