aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:03:13 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit86be73d6f9c7a9f2cea756aaaaead1d996d27a5d (patch)
treee66855cd6a471f402d18cbd01ef2815ceddf0a3a
parentb788e3e3b62aebc1713c3dfed81dffbe26eb35cf (diff)
downloadguix-86be73d6f9c7a9f2cea756aaaaead1d996d27a5d.tar
guix-86be73d6f9c7a9f2cea756aaaaead1d996d27a5d.tar.gz
gnu: Add ruby-rb-inotify.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cd36e01740..fa7d120032 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7606,3 +7606,25 @@ https://github.com/flavorjones/loofah-activerecord).")
"Creates a version constraint of supported Rubies,suitable for a gemspec file")
(home-page "https://github.com/e2/ruby_dep")
(license license:expat)))
+
+(define-public ruby-rb-inotify
+(package
+ (name "ruby-rb-inotify")
+ (version "0.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rb-inotify" version))
+ (sha256
+ (base32
+ "1yfcp3065n08balljmxn0qzwhdbwwxn2h9z89wmydyfj2gq1p71d"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests are not included in the gem.
+ (propagated-inputs `(("ruby-ffi" ,ruby-ffi)))
+ (synopsis
+ "A Ruby wrapper for Linux's inotify, using FFI")
+ (description
+ "This package provides a Ruby wrapper for Linux's inotify, using FFI")
+ (home-page "http://github.com/nex3/rb-inotify")
+ (license #f)))