aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:58:33 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit47779dc5b5a2bdf3c72f443e4515b75671dbad94 (patch)
tree05b3c08c1f7e357a5711930a3a4889e58074914e
parenta084a5c1da93eba4efcfeb184915ee3c5e7227d4 (diff)
downloadguix-47779dc5b5a2bdf3c72f443e4515b75671dbad94.tar
guix-47779dc5b5a2bdf3c72f443e4515b75671dbad94.tar.gz
gnu: Add ruby-racc.
-rw-r--r--gnu/packages/ruby.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d72400c625..77005a29c9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7064,3 +7064,38 @@ https://github.com/flavorjones/loofah-activerecord).")
"This package provides a library for working with Abstract Syntax Trees.")
(home-page "https://whitequark.github.io/ast/")
(license license:expat)))
+
+(define-public ruby-racc
+(package
+ (name "ruby-racc")
+ (version "1.4.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "racc" version))
+ (sha256
+ (base32
+ "00yhs2ag7yy5v83mqvkbnhk9bvsh6mx3808k53n61ddzx446v1zl"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; tests fail to compile
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis
+ "Racc is a LALR(1) parser generator.
+ It is written in Ruby itself, and generates Ruby program.
+
+ NOTE: Ruby 1.8.x comes with Racc runtime module. You
+ can run your parsers generated by racc 1.4.x out of the
+ box.")
+ (description
+ "Racc is a LALR(1) parser generator.
+ It is written in Ruby itself, and generates Ruby program.
+
+ NOTE: Ruby 1.8.x comes with Racc runtime module. You
+ can run your parsers generated by racc 1.4.x out of the
+ box.")
+ (home-page
+ "http://i.loveruby.net/en/projects/racc/")
+ (license license:expat)))