aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:56:10 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit3e7e334ac588cb9c908c6c4aa9be9a8b6d3972e2 (patch)
tree249ab56e0db01a375950522f1436a0ed0b60f50c
parenta6a3c4a5fc2dc64aa234acd31140cd3e6859ac9d (diff)
downloadguix-3e7e334ac588cb9c908c6c4aa9be9a8b6d3972e2.tar
guix-3e7e334ac588cb9c908c6c4aa9be9a8b6d3972e2.tar.gz
gnu: Add ruby-rubocop.
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ae8a0a9dd6..d6bdfb2628 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6887,3 +6887,35 @@ https://github.com/flavorjones/loofah-activerecord).")
"RR is a test double framework that features a rich selection of double techniques and a terse syntax.")
(home-page "https://rr.github.io/rr")
(license license:expat)))
+
+(define-public ruby-rubocop
+(package
+ (name "ruby-rubocop")
+ (version "0.41.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rubocop" version))
+ (sha256
+ (base32
+ "02adr908a9l8nhdfjz137i20w1dv8mbfiamy0m9z9q0fvslfdxly"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; test files not included
+ (propagated-inputs
+ `(("ruby-parser" ,ruby-parser)
+ ("ruby-powerpack" ,ruby-powerpack)
+ ("ruby-rainbow" ,ruby-rainbow)
+ ("ruby-ruby-progressbar" ,ruby-ruby-progressbar)
+ ("ruby-unicode-display-width"
+ ,ruby-unicode-display-width)))
+ (synopsis
+ " Automatic Ruby code style checking tool.
+ Aims to enforce the community-driven Ruby Style Guide.
+")
+ (description
+ " Automatic Ruby code style checking tool.
+ Aims to enforce the community-driven Ruby Style Guide.
+")
+ (home-page "http://github.com/bbatsov/rubocop")
+ (license license:expat)))