aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:03:29 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit2f90e5ff79d937f4dd9215c18d540282f5bb5950 (patch)
tree26c6049995250868f180c3d6ba1e242f5e7e3e17
parent86be73d6f9c7a9f2cea756aaaaead1d996d27a5d (diff)
downloadguix-2f90e5ff79d937f4dd9215c18d540282f5bb5950.tar
guix-2f90e5ff79d937f4dd9215c18d540282f5bb5950.tar.gz
gnu: Add ruby-guard-rspec.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fa7d120032..d65afd75af 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7628,3 +7628,29 @@ https://github.com/flavorjones/loofah-activerecord).")
"This package provides a Ruby wrapper for Linux's inotify, using FFI")
(home-page "http://github.com/nex3/rb-inotify")
(license #f)))
+
+(define-public ruby-guard-rspec
+(package
+ (name "ruby-guard-rspec")
+ (version "4.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "guard-rspec" version))
+ (sha256
+ (base32
+ "1jkm5xp90gm4c5s51pmf92i9hc10gslwwic6mvk72g0yplya0yx4"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests require further dependencies e.g. gem_isolator.
+ (propagated-inputs
+ `(("ruby-guard" ,ruby-guard)
+ ("ruby-guard-compat" ,ruby-guard-compat)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "Guard::RSpec automatically run your specs (much like autotest).")
+ (description
+ "Guard::RSpec automatically run your specs (much like autotest).")
+ (home-page
+ "https://github.com/guard/guard-rspec")
+ (license license:expat)))