aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:58 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit27f3f845bb3879fde7ad7575ae20c6119ba5a335 (patch)
tree1ad0bbf4c2dda9fdc3be299f589cb8b7efe7ea69
parent93c774cbf54ccf78885438e59b27fe81cb03c6b9 (diff)
downloadguix-27f3f845bb3879fde7ad7575ae20c6119ba5a335.tar
guix-27f3f845bb3879fde7ad7575ae20c6119ba5a335.tar.gz
gnu: Add ruby-unicode-display-width.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 46fbbada97..c9734350e0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7395,3 +7395,25 @@ https://github.com/flavorjones/loofah-activerecord).")
"")
(home-page "")
(license license:expat)))) ;?
+
+(define-public ruby-unicode-display-width
+(package
+ (name "ruby-unicode-display-width")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "unicode-display_width" version))
+ (sha256
+ (base32
+ "194d70pfxq4d7rrk0vsk1dvj46ns2f350308khi7q5cvnmg3h1xs"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; test data not included in gem.
+ (synopsis
+ "[Unicode 1.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.")
+ (description
+ "[Unicode 1.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.")
+ (home-page
+ "http://github.com/janlelis/unicode-display_width")
+ (license license:expat)))