aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:43:40 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit11f993514e9b35bcfeda7403cae839edf1f05a43 (patch)
treef41cef032cd542c6ae3a9e9277baad7c7efbd13c
parentd1b824c09d1b3cea3aaab018cf960735a163d729 (diff)
downloadguix-11f993514e9b35bcfeda7403cae839edf1f05a43.tar
guix-11f993514e9b35bcfeda7403cae839edf1f05a43.tar.gz
gnu: Add ruby-coveralls.
-rw-r--r--gnu/packages/ruby.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a175a5e73e..cb3e24b5a1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7310,3 +7310,56 @@ https://github.com/flavorjones/loofah-activerecord).")
"Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests.")
(home-page "http://vcr.github.io/vcr")
(license license:expat)))
+
+(define-public ruby-coveralls
+ (package
+ (name "ruby-coveralls")
+ (version "0.8.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "coveralls" version))
+ (sha256
+ (base32
+ "1y6gzahhaymgcxcgm7y16sgbiafsb7i2flhy1sq4x1jizk8bih5s"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'extract-gemspec 'update-dependency
+ (lambda _
+ ;; Relax dependency to avoid conflicting versions in nio4r
+ ;; for instance.
+ (substitute* "coveralls-ruby.gemspec"
+ (("<simplecov.*") "<simplecov>)\n")
+ (("<tins.*") "<tins>)\n"))
+
+ #t))
+ (add-before 'check 'fix-dependencies
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ ((".*pry.*") "\n"))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-truthy" ,ruby-truthy)
+ ("ruby-webmock" ,ruby-webmock)
+ ("ruby-vcr" ,ruby-vcr)
+ ("git" ,git))) ; git is required for testing
+ (propagated-inputs
+ `(("ruby-json" ,ruby-json)
+ ("ruby-rest-client" ,ruby-rest-client)
+ ("ruby-simplecov" ,ruby-simplecov)
+ ("ruby-term-ansicolor" ,ruby-term-ansicolor)
+ ("ruby-thor" ,ruby-thor)
+ ("ruby-simplecov" ,ruby-simplecov)
+ ("ruby-tins" ,ruby-tins)))
+ (synopsis
+ "A Ruby implementation of the Coveralls API.")
+ (description
+ "A Ruby implementation of the Coveralls API.")
+ (home-page "https://coveralls.io")
+ (license license:expat)))